SQL Developer sur Oracle 19c
ATTENTION
!!!!! Lire attentivement la procédure d'installation, si vous rencontrez des problèmes, n'essayez pas de continuer la procédure. Il vous faut plutôt tenter de régler le problème sinon ca ne fonctionnera pas. Aussi, prenez le temps de lire la section "problèmes et solutions" car elle contient la solution à tous les problèmes vécus par les étudiants. Si vous ne réussissez pas par vous-même, veuillez contacter aide@fsg.ulaval.ca !!!!!
- 1 Windows - Installation de SQL Developer-20.4.1.407.0006-x64
- 2 Fedora- Installation de SQL Developer 22.2.1.234.1810
- 3 MacOSX - Installation de SQL Developer 20.4.1.407.0006
- 4 Problèmes et solutions
- 4.1 I/O Error sur les machines Mac
- 4.2 J'obtient l'erreur "ressource occupé" lors de mes requètes
- 4.3 Quel est mot nom d'utilisateur et mon mot de passe?
- 4.4 Comment puis-je changer mon mot de passe?
- 4.5 Comment désinstaller SQL Developer
- 4.6 Rien n’apparaîtrait dans "Alias de réseau" lors de la configuration initiale de SQL Developer
- 4.7 Au démarrage de SQL Developer, j'obtient le message "Unable to launch the Java Virtual Machine"
- 4.8 Dans SQL Developer, l'affichage du résultat de mes requêtes subit un changement de ligne automatique et est difficile à lire
- 4.9 Mise à jour Windows 8.1 KB3023607 cause des problèmes avec le client VPN Cisco AnyConnect
- 4.10 Autre problème avec le client VPN:
Windows - Installation de SQL Developer-20.4.1.407.0006-x64
Télécharger le fichier ZIP qui se trouve ici ---> Sqldeveloper-20.4.1.407.0006-x64
Faites l'extraction du contenu du zip sur votre ordinateur. Nous vous suggérons de l'extraire dans "c:\program files\SqlDeveloper"
Le logiciel à démarrer est "C:\Program Files\sqldeveloper\sqldeveloper.exe". Nous vous suggérons de créer un raccourci sur votre bureau pour accès rapide.
Assurez-vous d'être connecté au réseau de l'université à l'aide du client VPN. Vous devez installer et brancher le client VPN si ce n'est déjà fait à l'aide de l'adresse suivante: https://vpncampus.ulaval.ca
Vous trouverez les guides de configuration ICI
Vous devez l'exécuter et vous connecter afin de continuer à la prochaine étape.
Au démarrage, répondez "NON" à la question "Souhaitez-vous importer les préférences à partir d'une installation SQL Developer antérieure?"
Une fois le logiciel démarré, vous devez aller dans le menu "Outils / Préférences / Base de données/Compilateur PL/SQL et Régler le paramètre « Identificateur PLScope sur « Aucun ».
Ensuite vous devez aller dans le menu "Outils / Préférences / Base de données / Avancé / Répertoire tsnames" et pointer sur le répertoire d'installation de SQL Developer ("c:\program files\SqlDeveloper")
Assurez-vous que le répertoire mentionné ci-dessus contient bien le fichier "tnsnames.ora". Si vous, avez extrait sqldevelopper dans un répertoire différent, vous devez modifier le chemin. Ex.: c:\\Program Files\sqldeveloper\sqldeveloper1.8.xxxxx\oracle...."
Aussi, assurez-vous de cocher "Validation automatique"
Créer la connexion vers le serveur
Attention: Votre compte ne sera pas créé avant la fin de la période de modification des choix de cours, comme il y a beaucoup de changements à la liste des comptes à créer avant cette date. Cette période se termine normalement à la 2e semaine de la session. Vous serez informés par courriel quand votre compte sera prêt. Vous pourrez ensuite créer la connexion et continuer l'installation.
Créez maintenant une nouvelle connexion. Inscrire "Oracle 19c" dans le champ "Nom de connexion",
votre nom d'utilisateur et mot de passe (C##IDUL) dans "Nom utilisateur", et votre mot de passe dans "Mot de passe".
Ensuite, choisissez TNS dans "Connection type" et dans Network Alias, choisissez "ORA19C"
Pour finir, dans l'ordre, cliquez sur "Tester", Enregistrer" et "Connexion"
Fedora- Installation de SQL Developer 22.2.1.234.1810
Telecharger le fichier rpm pour les machines Linux RedHat -→ sqldeveloper-22.2.1.234.rpm
Téléchargez le fichier suivant
Faite l'extraction du fichier (tnsnames.ora) dans vos document et souvenez-vous de son emplacement
Dans terminal ecrivez sudo yum install -y java-1.8*
Une fois l'installation terminée, tapez /opt/sqldeveloper/sqldeveloper.sh
Le programme commencera
Aller dans le menu Tools > Préférences > Advanced
Créez une nouvelle connexion: Name Ora19, username C##IDUL, mot de passe, Connection Type TNS, Network Alias ORA19C
Vérifiez la connexion en cliquant le buton Test en suite sauvegardez votre connexion
MacOSX - Installation de SQL Developer 20.4.1.407.0006
Assurez-vous d'avoir préalablement installé la version de Java JDK 11 qui est disponible ici
Télécharger le fichier ZIP qui se trouve ici ---> sqldeveloper-22.2.1.234.1810
Double cliquez sur le fichier ZIP. Cela devrait extraire un fichier "SQLDeveloper.app" dans le même répertoire
Déplacer le fichier extrait (SQLDeveloper.app) dans vos applications MAC
Téléchargez le fichier suivant
Faite l'extraction du fichier (tnsnames.ora) dans vos document et souvenez-vous de son emplacement
Démarrez l'application SqlDeveloper
Assurez-vous d'être connecté au réseau de l'université à l'aide du client VPN. Vous devez installer le client VPN si ce n'est déjà fait à l'aide de l'adresse suivante: https://vpncampus.ulaval.ca
Vous trouverz les guides de configuration ICI
Vous devez l'exécuter et vous connecter afin de continuer à la prochaine étape.
Une fois le logiciel démarré, vous devez aller dans le menu "Outils / Préférences / Base de données/Compilateur PL/SQL et Régler le paramètre « Identificateur PLScope sur « Aucun ».
Aller dans le menu "Oracle SQL Developer / Preferences ... / Base de données / Avancé / Répertoire tsnames" et pointer sur le répertoire où vous avez extrait le fichier tnsnames.ora
Aussi, assurez-vous de cocher "Validation automatique"
Créer la connexion vers le serveur
Attention: Votre compte ne sera pas créé avant la fin de la période de modification des choix de cours, comme il y a beaucoup de changements à la liste des comptes à créer avant cette date. Cette période se termine normalement à la 2e semaine de la session. Vous serez informés par courriel quand votre compte sera prêt. Vous pourrez ensuite créer la connexion et continuer l'installation.
Créez maintenant une nouvelle connexion. Inscrire "Oracle 19c" dans le champ "Nom de connexion",
votre nom d'utilisateur et mot de passe (C##IDUL) dans "Nom utilisateur", et votre mot de passe dans "Mot de passe".
Ensuite, choisissez TNS dans "Connection type" et dans Network Alias, choisissez "ORA19C"
Pour finir, dans l'ordre, cliquez sur "Tester", Enregistrer" et "Connexion"
Problèmes et solutions
I/O Error sur les machines Mac
Si vous obtenez un message d'erreur lorsque vous souhaitez chercher le fichier tnsnames.ora, simplement sauvegardez le fichier dans /USERS/VOTRE_USER/, et continuez la configuration.
J'obtient l'erreur "ressource occupé" lors de mes requètes
Si vous n'avez pas activé la Validation automatique et que votre connexion avec le serveur est coupée. Vous aurez alors des lock (verrous) sur vos tables:
Vous assurez de l'activer (voir instructions d'installation à ce sujet) pour ne plus que ça se reproduise
Contacter l'enseignant en précisant votre compte Oracle et le fait que vos tables sont verrouillées. Il pourra vous débloquer.